Hands On Chip Rev C

Home Forum Digitale Hands On Chip Rev C

Questo argomento contiene 5 risposte, ha 2 partecipanti, ed è stato aggiornato da  GRUNZ 5 giorni, 1 ora fa.

  • Autore
    Articoli
  • #8378 Risposta

    UDoKuoio
    Partecipante

    Non ho resistito alla tentazione di vederne uno e mi sono recato da Gil a Pavia, che invero era un po’ che cercava un tester per l’occasione… comunque… abbiamo riscontrato qualche difficolta’ e, alla fine qualcosa non torna. Elenco quindi con questo topic cio’ che ho combinato e vediamo dove ho sbagliato.

    SITUAZIONE INIZIALE: orientando a “nord” i fili per il pickup – giusto per aiutarci nella descrizione – ha i fili per il motore a SUD (con un “Ferrite Man”), a EST l’antenna e a OVEST una piattina che posso immaginare sia il “sensore di giro” di cui si parla nelle istruzioni. La piattina ha una contattiera “maschio” infilata nella f”femmina” con i contatti verso il basso. E’ un po’ ballerina, quindi mi assicuro meccanicamente ed elettricamente che ci sia il contatto. Sotto c’e’ la vite (da spostare in caso di cambio sistema) nel buco piu’ ESTERNO.

    Gil mi dice che il chip e’ configurato con il firmware O2 e quindi provvediamo ad installare il firmware Carrera. Alimentiamo il chip mettendolo sulla pista; sapendo che la Carrera ha la tensione invertita rispetto allo “standard”, INVERTO I FILI DEL PICKUP la cosa pare funzionare, nel senso che si accende il led rosso del chip.

    Ok: Mentre Gil ha aperto il programma della Nordic per l’aggiornamento, io predispongo il chip per la modalita’ DFU: magnete in fondo alla piattina, molto vicino senza toccarlo. Riaccendo il chip diverse volte invertendo anche il magnete per via della polarita’: nulla; il led rimane acceso e il programma NON trova il chip.

    Mi porto il chip a casa e proseguo. Prima di tutto mi scarico il software della Nordic ed il firmware per il protocollo Carrera. Curiosamente il mio smartphone vuole a tutti i costi scompattare al momento del download il file zippato, creando una cartella con 3 file. Non sono un sistemista… ma non mi piace la cosa,
    Insisto in qualche modo ed ottengo finalmente in file O21c-D132-0002-170711.zip sullo smartphone.

    Ripreparo il chip su un telaio. magnete “incartato” (non si sa mai) e via.
    Dopo un paio di tentativi, il led del chip – al momento dell’accensione – emette un brevissimo lampeggio e finalmente il programma “vede” un dispositivo con un nome tipo “02dfu2car”.. . Ci vuole un po’ per convincere il programma a caricare il file di cui sopra (non so perche’) .. e quando lo carico mi sparisce il chip… seguono 2-3 upload falliti e finalmente uno giunto a segno (secondo il programma), con il led del chip che lampeggia costantemente!!!!! OLE’!

    Lo lascio li’ per un po’, poi spengo tutto, rimetto il chip in pista e lo codifico con la Control Unit. “Beeppa” se passato sopra i sensori della CU (anche troppo..), monto un motore.. ma non va.

    Collego la CU al software che  usiamo per la gestione gara: il chip segna l’ID giusto meta’ delle volte (ID1), spesso ID2, ogni tanto gli altri. Tensione ai capi dei fili per il motore: nulla (0.16v) premendo il gas del controller messo in tutti gli slot disponibili.

    Ho tentato di ripetere la procedura, ma non sono piu’ riuscito a rendere visibile il chip al programma. Quindi ora il problema principale e’ questo. A seguire gli ID erratici e la mancanza di tensione per il motore.

    Note:
    – i led Infrarossi sono accesi entrambi e rilevati dai sensori della CU.
    – il led rosso si accende per una frazione di secondo come fosse in DFU.. anche senza magneti in giro.

    Per ora mi fermo qui. Spero fra l’altro di non avere danneggiato in qualche modo il chip, troppo vicino alla pista alimentata per rendermi tranquillo.
    Se poi e’ proprio quello il problema beh… meno male, almeno e’ facile da risolvere!

    Passo e chiUDo e rimango in attesa.

    • Questo argomento è stato modificato 1 mese fa da  UDoKuoio.
  • #8670 Risposta

    UDoKuoio
    Partecipante

    Nel frattempo i test sono progrediti molto positivamente e siamo in odore di pubblicazione di recensione. Stay tuned!

  • #8694 Risposta

    UDoKuoio
    Partecipante

    Difficile recensire qualcosa in evoluzione.

    Di solito nello slot se qualcosa non va, o lo si tiene cosi’ o si aspetta (e spera in) una nuova versione del prodotto. E invece ora… ….il chip non risponde ad un comportamento standard? Et voila’, nuovo firmware e tutto si sistema. Manca qualcosa? Prossimo aggiornamento! C’e’ una nuova idea? La troviamo subito!

    Come ex-videogiocatore, (abituato a add-ons e patch del programma) capite che ‘sta cosa mi piace parecchio.

    E passare dal sistema Scalextric al Carrera e viceversa richiede meno di 3 minuti, usando il nuovo metodo presente negli ultimi firmware. Mentre per SSD le cose sembrano gia’ consolidate, per Carrera – scopo dei test – si lavora anche per avere un feeling col mezzo superiore a quello degli altri chip in commercio, lavorando sulle curve di erogazione..

    Piccolo il chip. Molto piccolo, con 2 led per posizionarlo sia inline o ortogonalmente “alla Scalextric” evitando l’uso di un fly-led (opzione comunque prevista.).

    Altri test a seguire…

  • #8719 Risposta

    GRUNZ
    Partecipante

    Vedo che ci stiamo divertendo! 😉

  • #8806 Risposta

    UDoKuoio
    Partecipante

    Si. Molto.

    Lo piace studiare lo slot “al banco” per capire meglio cosa avrò in pista.

    E qualsiasi cosa che allontani il digitale da una dimensione “poco più che giocattolo” mi entusiasma.

  • #8823 Risposta

    GRUNZ
    Partecipante

    Una cosa che ho notato e’ che la vite per cambiare da AC a DC e’ montata sotto il chip. Questo vuol dire che se devo passare da SSD a Carrera o Oxigen, devo rimuovere il chip dallo chassis. Not a big deal, pero’ se la vite fosse stata installata sull’altra faccia il passaggio da un sistema all’altro avrebbe richiesto meno fiddling con il chip.

    g

Rispondi a: Hands On Chip Rev C
Le tue informazioni:




Annulla